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SPECbuilder 
Please see the SPECbuilder Guide for more information on using SPECbuilder. 

Word Online 
Please note that Microsoft Word Online is a cut-down version and does not have access to all the 

features that NATSPEC uses e.g. Show/hide hidden text, apply styles, etc. 

Macintosh – Pages 
NATSPEC is released in Microsoft Word format and is designed to work only with Microsoft Word. 

Pages will open and convert the NATSPEC Microsoft Word files: 

• Pages will not convert the hidden text (guidance and optional) that is used in the files. 

• Pages will not work with the Master document feature. You will have to merge the files 

manually. 

• Pages will convert Table of contents and it will be a clickable field. 

• You can insert your own Table of contents using Pages (Insert/Table of Contents/Document). 

You could continue to use Pages but you will be missing some features that Microsoft Word has. 

Windows 

Viewing Hidden Folders (Windows 10) 
In order to save the Template file in the appropriate location you need to be able to view Hidden 

folders. 

1. Open Windows Explorer 

2. Click the View Tab  

3. Check the Hidden items checkbox 
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Where to save the natspec.dotx file 

Windows 10 

1. Copy natspec.dotx 

2. Navigate to C:\Users\Your Log in\AppData\Roaming\Microsoft\Templates 

3. Paste the file 

Macintosh 

1. Copy natspec.dotx 

2. Navigate to Yourlogin\Library\Application support\Microsoft\Office\User Templates\My 

Templates 

3. Paste the file 

Microsoft Word 

Accessing the Developer Tab 
To work with Templates you will need access to the Developer Tab, which is not available unless you 

turn it on. To view the Developer tab: 

1. Click on the File Tab. 

2. Click the Word Options button. 

3. Click Customize Ribbon. 

4. Make sure Developer is ticked on the right hand column. 
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Attaching the NATSPEC Template file (natspec.dotx) to a document 

Word (Windows) 

1. Click on the Developer Tab 

2. Click on Document Template button 

3. Click on Attach 

4. Navigate to the location where natspec.dot is saved 

5. Click on Automatically update document styles 

6. Click on OK 

 

 

 

Word (Macintosh) 

1. Click on the Tools menu 

2. Choose Templates and Add-ins 

3. Click on Attach 

4. Navigate to the location where natspec.dot is saved 

5. Click on Automatically update document styles 
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6. Click on OK 

 

 

 

 

 

 

 

Working with a Master Document 

What is a Master document? 

SPECbuilder creates what is called a Master Document from the worksections selected for your 

project. 

A Master Document is a feature found in Microsoft Word. It is basically a standard Word document 

with links to other Word documents. 

 

Figure 5a: A Microsoft Word Master Document – as created by SPECbuilder 

The following instructions guide you through expanding these links. The final document will look like 

a fully merged file. The master document and each of the subdocuments are linked – any changes 
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you make to either will appear in both. Once the document is fully expanded you can go back to 

Page Layout view and update the Table of Contents or make any global changes that are required. 

RECOMMENDATION: It is recommended that the bulk of the editing required be done in each of the 

individual worksection files rather than the Master Document. There will be far less problems with 

Microsoft Word if you use the Master Document only for generating/updating the Table of Contents, 

searching for prompts and any global changes that may need to be made. 

For more information look at the Microsoft Word Help section on Master Documents. 

Using a master document 

Open the merged document. The document will have hyperlinks to all the subdocuments 

(worksections). 

1. To expand the document, go to View Ribbon and click Outline. 

 

View Ribbon 

2. On the Outlining Ribbon click the Expand subdocuments button to see the document in full. 

 

Outlining Ribbon 

Error when opening the Master document 

When opening a Master document for the first time you may get an error “Word found unreadable 

content in filename. Do you want to recover the contents documents? If you trust the source of this 

document, click yes.”. 

This just means that Microsoft Word’s security has identified this file as being a downloaded file. 

Word security needs to be adjusted in order to read the master document: 

• Open Word – just a blank file will do 

• Go to File/Options 

• In Word Options on the left hand side column select Trust Center 
• Click Trust Center Settings button 

• Make sure the first 2 checkboxes are unchecked 

• Click OK and OK again. 
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Merging a document manually and quickly 

Word (Windows) 

A feature in Word is Insert/Object/Text from file. This function can very quickly merge a large 

number of Word documents into a separate, single, stand-alone document. 

1. Open a blank document 

2. Selection the Insert Tab, Click the arrow to the right of the Object button, select Text from file. 

3. Navigate to your project folder 

4. Select All (Ctrl A) 

5. Keeping a finger on the Ctrl button of the keyboard, deselect any documents that should not be 

included in the merged document 

6. Select Insert 

7. Insert Page Breaks between worksections and attach the NATSPEC template (if required). 

8. Give the file a name and save the document 

This method is similar to a ‘cut and paste’, it will paste the documents in classification order and the 

only thing that needs to be done is inserting a Page Break between worksections. 
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Word (Macintosh) 

A similar function exists on the Mac OS, except that multiple files cannot be inserted at once – each 

file needs to be selected individually. This may seem tedious but is still a reasonably quick and 

effective method for joining multiple files into a single document. 

1. Open a blank document 

2. Select Insert/File 

3. Navigate to Project folder and select the file to insert 

4. Continue until all files are inserted 

5. Insert Page Breaks between worksections and attach the NATSPEC template (if required) 

6. Give the file a name and save the document 

NOTE: You can also use this feature to insert/add individual worksections to your merged document, 

whether it be manually merged or a Master document. 

Show or hide the guidance (hidden) text 

Use the Paragraph button on the Home Ribbon to quickly show and hide the hidden text. 

You can also go to the File tab, select Word options, Select Display and select Hidden Text. 

Table of Contents 
The Table of Contents (TOC) is generated from the Style headings – another reason for the use of 

styles. If a heading does not appear in your TOC then make sure it is styled correctly. 

The TOC is not automatically updated. This means that if you make any pagination changes the page 

numbers won’t automatically adjust themselves. You will need to update the field (right-click over 

the top of the field and choose Update Field or press F9). 

Also when generating the TOC or updating the field ensure that the Instruction (hidden) text in the 

document is either not visible or is deleted. If it is visible it will affect the pagination of the 

document. 

Inserting a Table of Contents 

Word (Windows) 

1. Click in the document where you want the Table of Contents to appear 
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2. Click the References tab 

3. Click the Table of Contents button 

4. Select Insert Table of Contents … 

 

Note: The Table of Contents is a Field. It does not update as you make changes to the document. To 

update the Table of Contents 

1. Right click over the top of the Table of Contents 

2. Choose Update Field 

3. If only page numbers have changed in the document, select Update page numbers only 

If headings have changed, select Update entire table 

4. Click OK 
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Word (Macintosh) 

1. Click in the document where you want the Table of Contents to appear 

2. Click the Insert menu 

3. Click Index and Tables … 

4. Select Table of Contents 

5. Check the preferences (usually only the Level) 

6. Click OK 

 

Note: The Table of Contents is a Field. It does not update as you make changes to the document. To 

update the Table of Contents 

1. Press [ctrl] and click to the left of the TOC and A quick menu appears. 
2. Select Update Field 

The Update Table of Contents dialog box appears. 
3. If only page numbers have changed in the document, select Update page numbers only 

If headings have changed, select Update entire table 
4. Click OK  

Section breaks 
Section breaks are different from standard Page breaks as follows: 

• Allow you to have different headers and footers within the same document 

• Allow you to have different page formats within the same document e.g.  

. one section of your document has two columns the next does not 

. different margins between sections of the same document 

. one section portrait and another section landscape 

Section breaks are located under Layout/Break. 

• Next page inserts a section break and starts the new section on the next page. 

• Continuous inserts a section break and starts the new section on the same page. 

• Odd page or Even page inserts a section break and starts the new section on the next odd-numbered or 
even-numbered page. 
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Managing Headers and Footers 
The headers and footers in a NATSPEC document are used to identify the worksection and for date 

information. They are fully editable and specifiers should use this area to insert any project 

information they require. Documents can have different headers and footers in the same file – you 

just need to insert a section break between pages and make sure the headers/footers between each 

section is not linked. 

Outline View 
Outline View in Microsoft Word allows the user to collapse the document down to its headings. This 

can be very useful at the beginning of the editing process when you want to delete clauses that are 

not applicable to the current job. In Outline View it’s possible to delete whole clauses by just 

selecting the heading and pressing the Delete button. 
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Finding and replacing 
This is one of the most overlooked features in Microsoft Word. Find and replace is an excellent 

feature for formatting large documents – especially if you receive files from outside sources and 

want to make them more consistent with your own. 

The Find and replace dialog box has a button on the bottom left-hand side called More. When you 

click on the button the dialog box enlarges and you get more features. 
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The usefulness of Find and replace is that you can find styles or formats and replace them with 

other styles or formats. 

For example if someone sends you a file and instead of using Heading 2 they’ve used a style called 

Subsection you can search your document for all paragraphs called Subsection and replace it with 

the Heading 2 style or if there is red text throughout the document you can search on any font that 

is red and replace it with black. This way the document is consistent as well as making sure all the 

headings appear in the Table of Contents. 

Recovering a corrupted file 
This trick works about 90% of the time. A corrupted file can act strangely, it does unexpected things. 

Sometimes a file becomes corrupted because your machine crashed while the file was open, or it 

was sent to you from someone else, etc. If you can at least open the file then give this a go. 

Open the file and Select All (Ctrl A). Then press the Shift key down and press the left arrow on 

your keyboard. This deselects the last paragraph marker of your document. Once you have done this 

you can Copy (Ctrl C) and Paste (Ctrl V) the text into a new blank document. 


